Current version of the OpenAuto Pro is 12
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bafx obd2 bluetooth
Did you try to lower baudrate to 9600? Please also provide new logs.
If you're using bafx bluetooth obd2, device type=2
thanks for the input MM however I stated earlier that now I switch to the USB that the blue wave people have recommended and have used before. this is a USB one and therefore needs to be set to type one.

ok, I just got a new samsung 32 gb sd card and flashed it with OA. I did everything the same , change the device type to 1 and the Descriptor to the /dev/ttyUSB0 and left the baudrate at the 115200. I had the same result of nothing on the gauges. I then changed the baudrate to 9600. Still the same issue. However I did notice that I may not have selected the whole log while posting it last time, as I used nano to open it and didnt realize it wasnt displaying the whole log. so here is the whole log with the 9600 baudrate setting.
[2021-01-09 20:54:34.740737] [0xb0ab1010] [warning] [OpenAuto] [Cache] failed to read configuration file: .openauto/cache/$
[2021-01-09 20:54:34.770577] [0xb0ab1010] [warning] [OpenAuto] [RecentAddressesList] failed to read configuration file: .openauto/cache/ope$
[2021-01-09 20:54:34.865800] [0xb0ab1010] [info] [OpenAuto] [VolumeManager] looking for default mixer.
[2021-01-09 20:54:34.865957] [0xb0ab1010] [info] [OpenAuto] [VolumeManager] automatic mixer selection, id: 0
[2021-01-09 20:54:34.866018] [0xb0ab1010] [error] [OpenAuto] [VolumeManager] unable to find selem name.
[2021-01-09 20:54:36.310906] [0xa4ffb140] [info] [OpenAuto] [AndroidAutoManager] initialized display region width: 800, height: 455, x: $
[2021-01-09 20:54:36.311096] [0xa4ffb140] [info] [OpenAuto] [AndroidAutoManager] initialized screen geometry width: 800, height: 455, x:$
[2021-01-09 20:54:36.317385] [0xb0ab1010] [error] [OpenAuto] [StorageMusicManager] selecting directory error: filesystem error: recursive$
[2021-01-09 20:54:36.317550] [0xb0ab1010] [info] [OpenAuto] [BluetoothSubsystem] starting bluetooth manager service.
[2021-01-09 20:54:36.319426] [0xb0ab1010] [info] [OpenAuto] [DayNightController] openauto manual mode changed, mode: 1
[2021-01-09 20:54:36.319535] [0xb0ab1010] [debug] [OpenAuto] [GestureSensorManager] start.
[2021-01-09 20:54:36.319593] [0xb0ab1010] [debug] [OpenAuto] [GestureSensorManager] sensor is not configured.
[2021-01-09 20:54:36.319648] [0xb0ab1010] [debug] [OpenAuto] [RearCameraController] start.
[2021-01-09 20:54:36.319830] [0xb0ab1010] [debug] [OpenAuto] [ObdManager] start.
[2021-01-09 20:54:36.320081] [0xb0ab1010] [debug] [OpenAuto] [TemperatureSensorManager] start.
[2021-01-09 20:54:36.320145] [0xb0ab1010] [warning] [OpenAuto] [TemperatureSensorManager] empty sensor descriptor.
[2021-01-09 20:54:37.702328] [0xa47fa140] [info] [OpenAuto] [AndroidAutoManager] triggering USB connection.
[2021-01-09 20:54:37.702493] [0xa47fa140] [info] [OpenAuto] [AndroidAutoManager] wait for usb device.
[2021-01-09 20:54:37.703227] [0xa47fa140] [info] [OpenAuto] [AndroidAutoManager] usb start, No AOAP device detected.
[2021-01-09 20:54:37.714573] [0xb0ab1010] [info] [OpenAuto] [OpenAuto] initializing interprocess routines.
[2021-01-09 20:54:37.715167] [0xb0ab1010] [info] [OpenAuto] [OpenAuto] initialized interprocess routines.
[2021-01-09 20:54:37.752015] [0xb0ab1010] [info] [OpenAuto] [HandsFreeModemsList] telephony availability changed: true
[2021-01-09 20:54:37.752158] [0xb0ab1010] [info] [OpenAuto] [HandsFreeModemsList] looking up modems, availability: true
[2021-01-09 20:54:37.752631] [0xb0ab1010] [info] [OpenAuto] [BaseEqualizerManager] server address call finished, result: 0
[2021-01-09 20:54:37.752829] [0xb0ab1010] [info] [OpenAuto] [BaseEqualizerManager] connecting to server: unix:path=/run/user/1000/pulse/$
[2021-01-09 20:54:37.754233] [0xb0ab1010] [info] [OpenAuto] [BaseEqualizerManager] connection result: true
[2021-01-09 20:54:37.756077] [0xb0ab1010] [info] [OpenAuto] [BluetoothSubsystem] bluetooth service start finished, value: 2, error: 0
[2021-01-09 20:54:37.759190] [0xa4ffb140] [info] [OpenAuto] [AndroidAutoManager] wait for usb device.
[2021-01-09 20:54:37.781990] [0xa47fa140] [info] [OpenAuto] [AndroidAutoManager] initialized display region width: 800, height: 452, x: $
[2021-01-09 20:54:37.782318] [0xa57fc140] [info] [OpenAuto] [AndroidAutoManager] initialized screen geometry width: 800, height: 452, x:$
[2021-01-09 20:54:38.874002] [0xb0ab1010] [info] [OpenAuto] [LadspaEqualizerManager] get sink by name call finished, result: 1
[2021-01-09 20:54:38.915038] [0xb0ab1010] [info] [OpenAuto] [BluetoothSubsystem] bluetooth manager start finished, value: 100
[2021-01-09 20:56:07.609098] [0x9caff140] [info] [OpenAuto] [ObdSerialTransport] open result: true
[2021-01-09 20:56:07.609292] [0x9caff140] [info] [OpenAuto] [ObdDevice] initializing, sequence: ATZ;ATE0;ATS0;ATL0;ATH0;ATSP0

I can change it back and post the 115200 baudrate setting log if you think it would be usefull.
Also if you would like to use Teamviewer to log into the actual unit I can give you the ID and password in a personal PM. I will be putting Teamviewer on it now just in case.
Looks like communication hangs on startup sequence phase. What firmware version has your ELM327 adapter?
I got this which was recommended by you guys in another post:

I'm not sure the firmware version unless it's that 1.5 number in the description. I find it kind of odd that I get the same issue with five different OBD 2 devices to being USB adapters and three being Bluetooth adapters.

how are you telling that it hangs during the startup sequence is it this log:
AndroidAutoManager] usb start, No AOAP device detected

also you custom make each image I assume for the CD key. is it possible something got screwed up while making my image, and it's the image fault that the USB keeps hanging?

okay guys I just realized something it's been a week troubleshooting this thing. can you guys tell me or confirm for me The exact device you guys are using on the exact firmware you're using with which pie you're using it on? I want to make sure everything's the exact same because this is just getting very frustrating. by the way this is a brand new pie too and I did use a version 3 plus before I switched to this pie 4 with 4 gigabytes. I have about 25 more pies to test if you think it's the hardware which I doubt at this point.
We were able to get an access to non-genuine (chinese clone) ELM327 adapter and test it. We discovered non-standard behavior - adapter works only with 38400 baudrate. We did not observe such issue with any of our genuine ELM327 adapters. Some small improvements have been introduced in order to handle that.

Could you please:
1. In case you already have access to version 12: re-download and re-apply update script or re-download and reflash the image with version 12? We renewed the links so they remain the same.
2. In case you do not have access to version 12: please follow the update procedure
3. With a freshly downloaded and installed version 12 set baudrate of OBD device in openauto_system.ini to 38400 and check if issue is gone?
I finally got it to work with a new download and re-flash of the SD card. It refused to work with the wifi OBD2 adaptors but finally worked with the USB adaptor. The settings I tried were the same except for the baud rate that I changed to the 38400. I will change it to 96000 and 115400 tomorrow.
Im not sure but you may have a issue with the old version 12 I have downloaded before this newer version. I can check it out later.
I will say I always skipped the updated when I went into the startx raspi interface. But this time i did do the update. Maybe that was it?
thank you for bearing with me. I truly appreciate it.

Forum Jump:

Users browsing this thread: 1 Guest(s)