Current version of the OpenAuto Pro is 12
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ODB2 PID Temperature 0105 - Bad reading
#1
I have the ELM327 , bluetooth working fine , except the reading of the PID 0105, that is not working. Most times does not send any value , and other ones the value shown in the gauge is -33. Dodgy

When I read it with other tools ( tablet + ELM327 ) the reading seems ok.

Is it possible to debug it, to know what is my car sending to Openauto ?

Thanks !!!!
Reply
#2
Value sent by ELM327 is taken into formula and then displayed on gauge. 0105 is standard PID. Are you sure that your tablet is reading the same pid for temperature?
Reply
#3
[attachment=799 Wrote:     BlueWave pid='11624' dateline='1598777128']Value sent by ELM327 is taken into formula and then displayed on gauge. 0105 is standard PID. Are you sure that your tablet is reading the same pid for temperature?

Yes ( this is what i think ) . Attached the screenshot, in this case my smartphone. The reading is pid 0105, 70C in this case. I tried several applications, engine on/off , etc, I checked the formula in the .ini file , but it seems Openauto it is not reading properly ( timeouts ?, retries ? ) or is reading other address or other byte. 

Thanks

And just FYI, the reading of the intake temperature, that is same formula but different PID, is correct.

Thanks for your interest
Reply
#4
OpenAuto Pro follows the standard. Standard response for 0105 PID is one byte length and formula is A-40. It works for all cars that we tested. Please provide log file (/home/pi/.openauto/cache/openauto.log). Also please check if your ELM327 adapter does not require additional commands after startup. It can be adjusted via ObdAdapterStartupSequence parameter in config file.
Reply
#5
It looks like ELM327 responds 7 for the pid query. 7 is often beginning of the ECU address (e.g. 7E0). It might be that ELM327 includes ECU address in 0105 response. Please try to change formula of the 0105 PID to (a * 0) + (b * 0) + (c-40) and post the result. However it should not include the ECU address when ATH0 command is present. Do you use genuine ELM327?
Reply
#6
I tried :

a-40 = Result = -30 in the screen
a*0 + (b-40) = -40 in the screen
a*0 + b*0 + (c-40) = -40 in the screen
a*0 + b*0 + c*0 + ( d-40 ) = -40 in the screen

The rest of the parameters works fine ( rpm , intake temp, load, etc ....) . I have a nice photo of it that can not post , it is 8MB

The protocol is ISO 9141-2 , Jaguar XK8 - 2000

I tried ATSP3, ELM327 Bluetooth but it did not work. Seems genuine but.....

The file openauto.log does not exist, no idea how to enable the log.

Thanks for your support in the troubleshooting !!!!
Reply
#7
Logs should be enabled by default. You can try to quit OpenAuto Pro and run it directly in the console via autoapp command and provide us console output.

Edit:
It might be also worth to try increase ObdProbePeriod to e.g. 100-300ms and do the retest.
Reply
#8
Attached the log.txt captured in the terminal screen.

Tried  with 200 & 300 ms and did not work.

Hope this helps
.txt   log.txt (Size: 6.74 KB / Downloads: 5)
Reply
#9
Looks like car returns nothing for 01 05 query. That is strange because 05 is on the list of supported PIDs. It would be good to check it with different adapter or check how mentioned Android app requests the 05 PID. OpenAuto Pro does it in exactly same way as the one described in ELM327 docs, but there might be something specific to the car.
Reply
#10
You are right. It seems specific to this car. I tried same configuration with a different car and works fine.
It is a Jaguar from 2000 and sends data , probably not according to the standard that Openauto does not understand and other clients yes. 
I'll make further investigations about the data format that Jaguar undestand as "standard" and will let you know.

Anyway, thanks for the support given on Sunday. :-) . Your application is really nice. 

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)